BRICO Anular sensores de nivel: fallo de catalizador acuda a taller P203D

¿Has tenido el problema y has aplicado este brico?


  • Votantes totales
    7

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Tarde o temprano les pasa a todos, los sensores consisten en tres barras dentro del cilindro del depósito, cada barra tiene un cable, que de abajo a arriba son: azul, rojo y amarillo que corresponden a sensor 2, sensor 1 y sensor 3. El que suele fallar es el sensor 3, el más corto, por lo tanto, el más alto y el que menos tiempo permanece sumergido y por tanto menos refrigerado. Cada barra conecta al común que es otra barra tan larga como el más bajo, a través de una resistencia de 4,3 kOhm.

El fallo viene por tiempo de uso y calentamientos y puede ser bien porque la resistencia del sensor se va, o bien sus soldaduras. Mientras el depósito está hasta arriba, no se presenta el error, dado que el adblue es conductor por lo que las señales de control se transfieren por el mismo a través de las otras barras.

El error se puede consultar en el siguiente enlace, el cual es del sensor 3:


Para hacer una idea de los colores de los cables, presento la siguiente imagen, del conector que va situado en el salvarueda trasera izquierda:

IMG_3466_Original.jpg

- El blanco y rosa más gordos y a la izquierda son los que alimentan el calefactor de depósito.
- Lo grueso negro del centro es un simple empalme que bifurga el gris en gris y negro.
- Negro y blanco finos son el sensor de temperatura.
- El gris antes de su bifurcación es común a todos los sensores.
- Azul, rojo y amarillo de la derecha son los tres sensores de nivel mencionados.

Empecemos con el BRICO:

1. Abrir la tapa del maletero por donde se rellena el adblue.

2. Desde ahí se pueden obsevar varias mangueras..., la que nos interesa es la que es una malla. La pestaña de sujección se puede levantar sin problema, va simplemente encajada.

IMG_0759.jpg

IMG_0760.jpg

3. Con un cuter, abrir la malla con cuidado de no dañar ningún cable.

IMG_0761.jpg

4. Lo más a la derecha posible, y tras la bifurcación con el negro... cortar los cables GRIS, AZUL, ROJO y AMARILLO. No tocar el resto de cables.

IMG_0762.jpg

5. Levantar las puntas de los cables cortados que quedan a la izquierda, pelar las puntas un par de centímetros y enroscarlas, metiédolas posteriormente en una borna eléctrica de dos tornillos (marca marrón) para asegurar la conexión. Encintar la borna para que no se moje al cargar adblue.

IMG_0763.jpg

6. Borrar los errores de la ECU con el OBD2 y software adecuado (mirar Forscan.org)

7. Dar una vuelta para que reconozca nivel máximo mostrando las 4 bolitas.

8. Dejarlo todo bonito e ir a cargar al máximo de adblue.

9. Programar rotación de neumáticos a 15.000km como aviso de rellenar adblue porque las bolitas ya no se apagarán y el coche siempre pensará que está al 100% de adblue.

Si has aplicado este BRICO, te has ahorrado unos cientos de euros, por favor colabora al mantenimiento de este foro. Que conste que mi aportación de conocimiento al mismo es altruista y no formo parte del equipo administrativo.

 
Última edición:

carlosCX7

Well-Known Member
Registrado
6 Diciembre 2019
Mensajes
53
Ubicación
Andalucia, bastante tiempo por Sevilla
Modelo
Mazda CX-7
Motor
2.2 DIesel
Este problema a mi todavía no se me ha dado en el coche, pero estoy seguro que me lo dará.

Entonces la solución era unir los cables rojo, amarillo, azul y gris (de la parte de donde vienen de la ECU,) es decir, la parte IZQUIERDA, ¿no?

Un saludo y muchas gracias por el brico.
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Si, pero después de la bifurcación con el negro.
 

Jmax

Member
Registrado
8 Enero 2020
Mensajes
6
Ubicación
Malaga
Buenas noches Alea. Ante todo, muchas gracias por tomarte las molestias de recuperar toda la información del foro antiguo y pasarla al nuevo. Mi caso es que me ha aparecido el fallo P20B9 y ando buscando la solución. ¿Sabes que debería hacer?
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Bueno, estos bricos los publiqué yo tras largo e intenso estudio y con la ayuda de algunos otros foreros que me enviaron piezas averiadas o hicieron pruebas conjuntas.

Tu error es fallo del calentador del depósito, te pongo link:


Y sí, tiene solución... hay quien cambió el calentador directamente, pero no dispongo de referencias, y es un brico algo tedioso.

Si no te mueves por zonas gélidas, lo puedes anular poniendo una bombilla de posición trasera en los cables rojo y blanco gordos y anulando el sensor de temperatura con la resistencia de 10kOhm. Esto último me consta que está funcionando en dos coches porque di las instrucciones para ello. La bombilla se encenderá por unos segundos en el test de inicio, por lo que hay que colocarla con algo de aislamiento y zona oculta, por ejemplo llevarla a la zona de acceso de piloto trasero.
 

Jmax

Member
Registrado
8 Enero 2020
Mensajes
6
Ubicación
Malaga
Muchas gracias Alea, este fin de semana me pondré con ello, tampoco puedo esperar mucho ya que me marca que me queda Adblue para 800 Km. He visto el Post de anular el sensor de temperatura y todo parece sencillo de hacer, vivo en Málaga y no viajo a zonas frías, por lo menos no por debajo de los 0º, con lo que no creo que tenga problemas.

Cuando lo tenga solucionado, comento.
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Ok, el sensor de temperatura tal vez te funcione, pero al poner la bombilla estás obligado a poner la resistencia no sea que reciba orden de calentar adblue y se quede encendida pudiendo quemar algo por calor.

ve buscando un casquillo o le sueldas los cables diréctamente y luego empalmas con bornas eléctricas a lo indicado.
 

Balder

New Member
Registrado
2 Enero 2020
Mensajes
1
Ubicación
Granada
Modelo
Mazda CX-7
Motor
DIESEL
Mi coche tiene este error cada 5 o 6000 Km y por ahora lo soluciono rellenado y el deposito de adblue (o sustituyo todo el adblue.
Ha sido un verdadero regalo de reyes volver a encontraros, muchos saludos a todos
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Si, es lo que comentaba.... si se rellena a tope, las señales se conmutan a través del adblue por las otras barras, pero cuando desciende el nivel y la barra más alta queda en seco, salta nuevamente el error.

En la encuesta tu voto debería ser, el que te aparece de vez en cuando, porque lo consigues camuflar, pero no lo has solucionado.

gracias
 

Jmax

Member
Registrado
8 Enero 2020
Mensajes
6
Ubicación
Malaga
Bueno, estos bricos los publiqué yo tras largo e intenso estudio y con la ayuda de algunos otros foreros que me enviaron piezas averiadas o hicieron pruebas conjuntas.

Tu error es fallo del calentador del depósito, te pongo link:


Y sí, tiene solución... hay quien cambió el calentador directamente, pero no dispongo de referencias, y es un brico algo tedioso.

Si no te mueves por zonas gélidas, lo puedes anular poniendo una bombilla de posición trasera en los cables rojo y blanco gordos y anulando el sensor de temperatura con la resistencia de 10kOhm. Esto último me consta que está funcionando en dos coches porque di las instrucciones para ello. La bombilla se encenderá por unos segundos en el test de inicio, por lo que hay que colocarla con algo de aislamiento y zona oculta, por ejemplo llevarla a la zona de acceso de piloto trasero.
Buenas tardes Alea, siguiendo tus instrucciones, parece que se ha solucionado el error, tras unos 50 km no salta el mensaje. Cortar cables rojo y blanco gordos, ponerles una bombilla de posición y cortar blanco y negro finos y unirlos con la resistencia. Lo más complicado, trabajar con los cables por el pequeño hueco de rellenado, tuve que soltar la clema de conexión detrás de la rueda, para poder tirar de ellos y sacarlos un poco.
Muchas gracias por la ayuda, seguiremos enriqueciendo el foro.
 

ElJOSELAMUSA

New Member
Registrado
16 Enero 2020
Mensajes
4
Ubicación
Huesca
Modelo
Mazda CX-7
Buenas tardes,
He seguido tus instrucciones y funcionó bien durante unos km pero después me volvió a saltar el aviso. Le he metido el OBD2 y me sale el código U0422 que hace no hace referencia a nada relacionado con el catalizador. También se nos soltó el tubo de salida y perdimos todo el líquido. A raíz de eso ha salido el código.
¿Qué podemos hacer? Porque no deja borrar el código.
Un saludo
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Si se te ha soltado el tubo del adblue, el sistema no toma presión, por lo que saltaría el error, si has solucionado los anteriores:


¿Como se te ha soltado el tubo, es que bajaste el depósito en vez de hacerlo por el agujero?

Los códigos U suelen ser por llevar algún aviso de avería en cuadro. Ese se borra conjuntamente al que lo produce y listo.
 

ElJOSELAMUSA

New Member
Registrado
16 Enero 2020
Mensajes
4
Ubicación
Huesca
Modelo
Mazda CX-7
Buenos días,

Bajamos el depósito para trabajar mejor. No debimos de poner el tubo bien hasta que hiciera el "click". Después de soltarse se perdió el líquido y debió de saltar el código en ese momento.

¿El sistema se coge presión solo? ¿Es posible que el código salga debido a que no tiene presión el sistema? Ya que no nos deja borrar el código.

Muchas gracias por tu ayuda.
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Si, la bomba es capaz de cargarse, cuando el coche apaga se retorna todo el adblue al depósito invirtiendo el circuito.

Posiblemente el tirón de soltarse la manguera puede haber soltado o dañado el conector del calentador de manguera, pero ese problema te saldría tras borrar errores y tras llevar unos 5 minutos rearrancado.

Deberías poder borrar todos los errores aunque fuere sólo con contacto puesto.
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Una cosa... te da fallo de catalizador en cuadro central o simplemente tienes ese error?

Porque el U0422 es un error genérico de transmisión de datos, se te puede haber mojado el sensor de nivelación de faros xenon (si los llevas) y estarte dando ese error.

Lo digo porque va bastante expuesto por dd el depósito de adblue
 

ElJOSELAMUSA

New Member
Registrado
16 Enero 2020
Mensajes
4
Ubicación
Huesca
Modelo
Mazda CX-7
Buenas tardes, el fallo del catalizador aparece en el cuadro central y el código sabemos cual es dado que hemos conectado un OBD-2 aunque no deja borrarlo.
Cuando pueda revisaré el sensor de nivelación que lleva justo allí.
Muchas gracias por tu ayuda
 

Alea

Well-Known Member
Registrado
5 Diciembre 2019
Mensajes
80
Ubicación
Madrid
Modelo
Mazda CX-7
Motor
2.2 CRTD
Si te da fallo de catalizador en cuadro... además del U... que otro error te marca?
 
Arriba